Restore from backup not working! Help!

sammysunlightsammysunlight Member
edited December 2016 in Bugs & Errors
I'm having major issues. I installed Goalist In November and used it thru the trial period and was so impressed that i bought a subscription. This app is complex so i was still learning it and customizing it. The custom notification sound i assigned to my tasks never worked and it's the main feature why i downloaded this app. I had been making regular backups so i decided to uninstall the app and reinstall it to see if that would fix the problem. But now i can't get Goalist to import my backup! I have sooooooo many tasks and information in Goalist and i need to access my data desperately! I have Multiple Sclerosis so my memory is poor and i rely on Goalist to keep me on track. PLEASE help!

I get the error below when i select ”goalist-2016-12-22”:
"Error: Java.io.FileNotFoundException: olddbcopybeforeimport (read only file system)"

When i select "goalist-2016-12-22.zip" i get a different error: 
"Android.database.sqliteSQliteCantOpenDatabaseException: unknown error (code 14): could not open database"

When i hit ok after the error messages, i get a small window that states "please wait" with a circle going around and around below it.

Please help me get my tasks restored... Please.

Comments

  • AdamAdam Developer
    Posts: 0
    Hi Sammy,

    Please don't worry, we'll work something out. Next time you have an urgent issue please write directly to our email to get a faster response.

    If you have Android 6 or higher, please check this permission:
    http://cambiastic.com/goalist/forum/discussion/comment/457/#Comment_457
    Otherwise please let me know your Android version.

    I see in the error message: "read only file system" so hope it's about a permission which was revoked after the reinstallation. I could also be a problem with your internal memory, but this should go away after a phone reboot..

    Anyway - these errors only mean that there's a problem accessing the file. So the backup should be fine and one way or another we'll be able to recover your data.
  • sammysunlightsammysunlight Member
    Posts: 7
    Hi Adam, thank you so much for your reply. I used the in-app link to report the error and it took me to this forum. I looked in the "inbox" section of my profile and the recipients field is empty and i don't see where your email is published. I'm so sorry for not finding it. I'll keep looking.

    I'll recheck my app permissions as you suggested and come back here and post my findings in a few minutes...
  • sammysunlightsammysunlight Member
    Posts: 7
    Basic info:
    Nexus 5X with latest Android Nougat

    Steps I've just taken:
    Settings > Apps > Goalist > storage
    ---clear data (it's a fresh empty install)
    ---clear cache

    Data usage > background data
    ---enabled

    Permissions > storage
    ---enabled
    Permissions > microphone
    ---disabled

    Notifications
    ---level 5 selected (highest level)

  • sammysunlightsammysunlight Member
    Posts: 7
    I have Opera Max installed as well but I've given Goalist full access.

    I've turned Opera Max savings off for Goalist.
    Background data is allowed for Goalist
    Mobile access is allowed for Goalist
    WiFi access is allowed for Goalist
  • sammysunlightsammysunlight Member
    Posts: 7
    Within Goalist:
    All modules are enabled except Periodeus and Automatic Backup (until i get this issue resolved, it was enabled previously)

  • sammysunlightsammysunlight Member
    Posts: 7
    I just tried restoring my database again and i get same errors. :(
  • sammysunlightsammysunlight Member
    Posts: 7
    Omg, cancel this trouble ticket. I fixed it. Haha!

    Problem:
    I had extracted the zip file that was created when i backed up my data. So i had two files in the Goalist > backup folder:
    Goalist-2016-12-22.zip
    Goalist-2016-12-22 (no file extension identified)

    Solution:
    1) Made a copy of both files above and put them in another folder outside of the main Goalist folder as a secondary backup.
    2) Then i removed Goalist-2016-12-22 (with no file extension) from the main Goalist > backup folder so only the zip file remained.
    3) Attempted to restore the database from within the Goalist app by selecting Goalist-2016-12-22.zip and it WORKED! I checked my categories and all my goals and tasks are there!

    I'm beyond ecstatic right now for having Goalist back in action! And so relieved that i can get back to being productive. Whew.

    Lesson learned:
    DO NOT EXTRACT THE ZIP FILE IN THE BACKUP FOLDER! I don't remember why i did that in the first place.

    Thank you, Adam, for replying to my desperate plea for help especially so close to the holiday season when so many people are busy and spending time with family & loved ones. You are truly a dedicated and loyal businessman and i appreciate you and your most excellent Goalist app.

    Happy holidays!

    Sammy
  • AdamAdam Developer
    edited December 2016 Posts: 0
    Great, I'm very happy you got it fixed! And thanks a lot for describing the issue so well, it's a good lesson for me as well.

    But there's still the problem of custom notification sounds not working for you. We can leave it for after the Holidays. But if you were willing to help me explore the issue I would be grateful (and surely other users that have the same problem).

    So Happy Holidays to you too and I hope to hear from you after them!

  • AdamAdam Developer
    edited December 2016 Posts: 0
    Hi Sammy - if your problem with sounds was as described in this post - it should be now fixed in version 5.2.4. Otherwise please describe the details of your issue next year.
Sign In or Register to comment.